weconnect-cli API (Python, Achtung: stark computerlastiges Thema)

  • Ich bin mir inzwischen sicher dass das an meinem User liegt. Ich habe mein Home auf einem Softraid, also per TB angebunden, und da ist ein Leerzeichen im Name. Das File, das Docker anmeckert, liegt im ~/Library… und wenn das anders gemountet ist, dann ist da eben mein Raid-Name (/Volumes/Externes Raid/Users…) mit drin, und ich vermute dass es ihn dabei schmeißt.

    Mal einen Bug mit Docker aufmachen, wenn ich einen normalen User mit normalem Home nutze, geht es. Also probier ich es ein anderes Mal auf meinem Linux-Rechner.

  • Erstmal vielen Dank an den Entwickler stein ! :thumbup:

    Ich habe die Docker-Komplettversion als VM (Proxmox x86, Ubuntu 20.04) laufen. Heute ist mir aufgefallen, dass man "sein" Fahrzeug ja noch konfigurieren muss (Akkukapazität, WLTP Reichweite). - Dann werden die Grafiken noch schöner. :D


    Ich werde aber mal schauen, wie ich das eigentliche Programm separieren kann, da ich bereits einen (eigenen) Grafana und postgeSQL Server (für ioBroker) laufen habe, und diese gerne nutzen würde. Ich bin leider nicht so der Docker-Profi.

  • Ich werde aber mal schauen, wie ich das eigentliche Programm separieren kann, da ich bereits einen (eigenen) Grafana und postgeSQL Server (für ioBroker) laufen habe, und diese gerne nutzen würde. Ich bin leider nicht so der Docker-Profi.

    das ist relativ einfach: Du installierst dir Python und machst dann:

    Code
    pip install vwsfriend

    Je nach System auf dem du läufst musst du eventuell vorher ein paar Abhängigkeiten installieren. Für Ubuntu 20.04 müsste das hier vermutlich reichen:

    Code
    apt-get install --no-install-recommends -y libpq-dev libffi-dev libssl-dev cargo libjpeg-dev zlib1g-dev

    Dann kannst du vwsfriend einfach von der Commandline starten:

    Code
    vwsfriend --username=${WECONNECT_USER} --password=${WECONNECT_PASSWORD} --interval=${WECONNECT_INTERVAL} --database-url=${DATABASE_URL} --config-dir=/config ${ADDITIONAL_PARAMETERS}

    Die Variablen musst du natürlich nicht mit deinen Einstellungen ersetzen.


    Für Grafana musst du diese Dateien an die richtigen stellen legen damit die Dashboards installiert werden:

    https://github.com/tillsteinbach/VWsFriend/tree/main/grafana


    Hier musst du nur dran denken dass du bei späteren Updates nicht nur vwsfriend updates sondern auch die dashboard Dateien da wo du sie abgelegt hast

  • Mein ID.4 ist zwar noch nicht da habe das Ding aber heute mal testweise auf meinem QNAP in der Containerstation installiert. Man muss nur vor dem starten die We-Connect Zugangsdaten bei advanced eintragen dann lüppt es sofort, zeigt bei mir nur leider noch nix an :D

    Renault Zoe seit 11/2017

    ID.4 Family (Scale Silver metallic), Ganzjahresreifen, AHK und WP bestellt am 15.4. letzter Liefertermin laut API 2.7.2021

    Modelljahrwechsel im Account am 22.05. von 2021 auf 2022

    FIN seit 05.09.2021 -> 0054XX Abholung am 8.10.2021 12:30 in WOB :love:

  • Du stein , nun hat es mich auch erwischt. Kannst Du hiermit was anfangen?


    Code
    vwsfriend_1   | 2021-10-11T19:04:03+0000:INFO:vwsfriend:vwsfriend 0.6.0 (using WeConnect-python 0.21.0)
    vwsfriend_1   | 2021-10-11T19:04:03+0000:INFO:weconnect:Could not use token from file /tmp/weconnect.token ([Errno 2] No such file or directory: '/tmp/weconnect.token')
    vwsfriend_1   | 2021-10-11T19:04:04+0000:CRITICAL:vwsfriend:There was a problem when authenticating with WeConnect: Password is invalid
    root_vwsfriend_1 exited with code 0


    Der WECONNECT_USER ist korrekt, das Passwort auch...

  • Vom Gefühl her ist es in 50% der Fälle der Server der Mist macht. Geht denn der Login auf myvolkswagen mit dem user/passwort?

    Was ich gestern hatte war dass ich den neuen Nutzungsbedingungen zustimmen musste. Das mache ich in der API bewusst nicht selber. Dafür muss man sich in der App einmal ab und wieder anmelden oder auf myvolkswagen neu einloggen.

  • mea culpa.... Das Passwort war doch falsch, und ich habe übersehen, dass Du beim richtigen nicht das Passwort beschimpfst, sondern das Token, und dass ein Throttle kam -.- Sorry, zu langer Tag.


    <NACHTRAG> stein Nun tut es, Grafana ist halt noch leer, aber das liegt denke ich mal an der leeren Datenbank. Ist ja noch nix drin. Also schaun wir mal. Läuft übrigens im Moment per Docker install auf Ubuntu 18 auf einem STRATO Server. HomeKit habe ich (noch) nicht integriert, dazu ists echt zu spät :)


    Lieben Gruß und Danke für die Arbeit!!


    S.

    2 Mal editiert, zuletzt von sunstarfire ()

  • Klingt gut!

    Wenn ich STRATO Server höre nur noch die Warnung: In VWsFriend ist nichts abgesichert! Ich will nicht ausschließen dass wenn jemand über das Internet an die Oberfläche dran kommt dass er ein Token klauen kann. Das ist zwar nicht so schlimm wie ein Passwort, aber trotzdem nicht schön. Also lieber alles gut absichern!

Jetzt mitmachen!

Drei Gründe dafür:
- Austausch mit VW ID. Fahrer
- Alles zu Versicherung & Finanzierung
- Tipps zum Fahren & Laden

Registriere Dich kostenlos und nehme an unserer Community teil!